1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Editor / BBCode Version not working properly?

Discussion in 'XenForo Pre-Sales Questions' started by Static-Xbox, Aug 1, 2010.

  1. Static-Xbox

    Static-Xbox Active Member

    Just wondering if this is how it's supposed to work, or if I've done something wrong; however, when I went to edit my signature, I switched to the BBCode Editor and typed the usual tags. It looked like this:

    [size=1][B].::[url=LINKHERE]link title[/url]::.
    url=LINKTWO]link two title[/url]::.[/B][/size]
    When I saved the changes and checked one of my posts, the signature had one line formatted properly, and one line improperly formatted. I went back to edit my signature again, and switched back to the BBCode Editor once again, and it had indeed swapped the tags to this:

    [B][/B][size=1][B].::[URL=LINK]link title[/URL]::.[/B][/size]
    URL=LINKTWO]link two title[/URL]::.
    I've gone back in and added the tags to each line of the signature (and decided to stick with a one-line signature, at that), so it's fine now; however, I wanted to check and see if this is a by-design feature, or if I did something wrong to make it swap the tags in that manner?

  2. Mike

    Mike XenForo Developer Staff Member

    The WYSIWYG editor will change the markup, which is a pain but generally unavoidable. Right now, the HTML to BB code converter is really ropey. The editor is something I've been focusing on a lot in the last few days, and I might have to re-approach several things to resolve some issues.
  3. Mike

    Mike XenForo Developer Staff Member

    Though actually, just to confirm something... Use the BB code editor to add some visible text and save. Does it show up? If not, what browser are you using?
  4. Static-Xbox

    Static-Xbox Active Member

    Hi Mike,

    Thanks for the quick response! I tried adding a few different things to the signature, including just plain text, and it does seem to save and work as normal (FireFox 3.6.8). Only issue I saw was the change in markup after saving with the BBCode Editor, which is something I'll keep in mind when using the BBCode Editor.

    Thanks :)

Share This Page