1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Fixed Draft save race condition

Discussion in 'Resolved Bug Reports' started by Mike, Jun 3, 2013.

  1. Mike

    Mike XenForo Developer Staff Member

    Looks like there's a potential situation where the draft save can fire off while the form is being submitted.
     
  2. TheBigK

    TheBigK Well-Known Member

    Does the system notify the user that it's saved the draft? I tried in test mesages forum but did not get any notification.
     
  3. sonnb

    sonnb Well-Known Member

    It is automatically saved. Write something, try to navigate away then come back, you would see your text is still there.
     
  4. DBA

    DBA Well-Known Member

    Does it save in real-time or every so many seconds? @Mike
     
  5. Jeremy

    Jeremy XenForo Moderator Staff Member

    @DBA, I believe its every minute it attempts to save.
     
  6. Jeremy P

    Jeremy P Well-Known Member

    As per the HYS thread, every x seconds (configurable I think), defaulting to every 60.
     
    DBA likes this.
  7. AndyB

    AndyB Well-Known Member

    I hope it's configurable so I can select zero seconds to disable this function on my forum.
     
  8. CyclingTribe

    CyclingTribe Well-Known Member

    TBH I was sure it was an ACP on/off option, but re-reading the HYS thread I can't see that it is.

    @Mike - can we enable/disable the draft saving feature?
     
    AndyB likes this.
  9. Mike

    Mike XenForo Developer Staff Member

    Fixed. Will be rolled out here soon.
     
    Shelley and tafreehm like this.
  10. seant04

    seant04 New Member

    Hi @Mike ,

    Is there a simple fix that won't require an upgrade to 1.2?
     
  11. EQnoble

    EQnoble Well-Known Member

    I think this only applies to 1.2 unless I stand corrected. (unless you are talking about an update to the beta you are testing currently)
     
  12. sonnb

    sonnb Well-Known Member

    1.1.5 and earliers do not have draft feature.
     
    CyclingTribe likes this.
  13. seant04

    seant04 New Member

  14. RobParker

    RobParker Well-Known Member

    Can the draft feature be disabled? I'm trying to debug why we get editor lag on some devices and wanted to check it wasn't due to the draft stuff.
     
  15. Moshe1010

    Moshe1010 Well-Known Member

    No, it's basically due to JS and it happens mostly on "weak" cellphones. The only solution for that is to tell people to use the simple editor.
     
  16. RobParker

    RobParker Well-Known Member

    What makes you say that?

    We're seeing lag with the iphone 5 and ipad 3 as well as new samsung phones. It's not consistent among devices (my iphone is fine but I do see it on my ipad).
     
  17. Moshe1010

    Moshe1010 Well-Known Member

    It is consistent with Samsung S2/3/HTC One and some other more. It depends mostly on the device itself (Hardware), and software (many custom roots are just terrible). I have an iPhone 5 and I have no issues with the editor. iPad 2 has slight lag when typing fast; I can't confirm iPad 3...
     
  18. RobParker

    RobParker Well-Known Member

    My point is it's not that simple. My iPad 3 is laggy, others have been fine. Equally my iPhone 5 is perfectly fine but we've had lots of other users complain about their iPhone 5 experiencing lag. The guys at PixelExit haven't been able to duplicate any lag but for me it happens on both our site and theirs pretty consistently with my iPad.
     
  19. Moshe1010

    Moshe1010 Well-Known Member

    Have you tried the default style on your website?
     
  20. RobParker

    RobParker Well-Known Member

    The default style was fine. We finally tracked it down to some box-shadow CSS causing the issue.
     
    Moshe1010 likes this.

Share This Page