• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Fixed Draft save race condition

Mike

XenForo developer
Staff member
#1
Looks like there's a potential situation where the draft save can fire off while the form is being submitted.
 

TheBigK

Well-known member
#2
Looks like there's a potential situation where the draft save can fire off while the form is being submitted.
Does the system notify the user that it's saved the draft? I tried in test mesages forum but did not get any notification.
 

sonnb

Well-known member
#3
Does the system notify the user that it's saved the draft? I tried in test mesages forum but did not get any notification.
It is automatically saved. Write something, try to navigate away then come back, you would see your text is still there.
 

EQnoble

Well-known member
#11
I think this only applies to 1.2 unless I stand corrected. (unless you are talking about an update to the beta you are testing currently)
 

RobParker

Well-known member
#14
TBH I was sure it was an ACP on/off option, but re-reading the HYS thread I can't see that it is.

@Mike - can we enable/disable the draft saving feature?
Can the draft feature be disabled? I'm trying to debug why we get editor lag on some devices and wanted to check it wasn't due to the draft stuff.
 

Moshe1010

Well-known member
#15
Can the draft feature be disabled? I'm trying to debug why we get editor lag on some devices and wanted to check it wasn't due to the draft stuff.
No, it's basically due to JS and it happens mostly on "weak" cellphones. The only solution for that is to tell people to use the simple editor.
 

RobParker

Well-known member
#16
No, it's basically due to JS and it happens mostly on "weak" cellphones. The only solution for that is to tell people to use the simple editor.
What makes you say that?

We're seeing lag with the iphone 5 and ipad 3 as well as new samsung phones. It's not consistent among devices (my iphone is fine but I do see it on my ipad).
 

Moshe1010

Well-known member
#17
What makes you say that?

We're seeing lag with the iphone 5 and ipad 3 as well as new samsung phones. It's not consistent among devices (my iphone is fine but I do see it on my ipad).
It is consistent with Samsung S2/3/HTC One and some other more. It depends mostly on the device itself (Hardware), and software (many custom roots are just terrible). I have an iPhone 5 and I have no issues with the editor. iPad 2 has slight lag when typing fast; I can't confirm iPad 3...
 

RobParker

Well-known member
#18
It is consistent with Samsung S2/3/HTC One and some other more. It depends mostly on the device itself (Hardware), and software (many custom roots are just terrible). I have an iPhone 5 and I have no issues with the editor. iPad 2 has slight lag when typing fast; I can't confirm iPad 3...
My point is it's not that simple. My iPad 3 is laggy, others have been fine. Equally my iPhone 5 is perfectly fine but we've had lots of other users complain about their iPhone 5 experiencing lag. The guys at PixelExit haven't been able to duplicate any lag but for me it happens on both our site and theirs pretty consistently with my iPad.