• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.2 Deadlock found with admin.php?add-ons/toggle

kezako

Active member
#1
My version of Xenforo 1.2.4

Zend_Db_Statement_Mysqli_Exception: Mysqli statement execute error : Deadlock found when trying to get lock; try restarting transaction - library/Zend/Db/Statement/Mysqli.php:214
Généré par: Garfieldisback, Lundi à 20:45
Trace de la pile

#0 /home/mywebsite/prod/library/Zend/Db/Statement.php(297): Zend_Db_Statement_Mysqli->_execute(Array)
#1 /home/mywebsite/prod/library/Zend/Db/Adapter/Abstract.php(479): Zend_Db_Statement->execute(Array)
#2 /home/mywebsite/prod/library/Zend/Db/Adapter/Abstract.php(661): Zend_Db_Adapter_Abstract->query('DELETE FROM `xf...')
#3 /home/mywebsite/prod/library/XenForo/Model/Template.php(1626): Zend_Db_Adapter_Abstract->delete('xf_template_phr...', 'template_map_id...')
#4 /home/mywebsite/prod/library/XenForo/Deferred/TemplatePartialCompile.php(55): XenForo_Model_Template->compileAndInsertParsedTemplate(3428, Array, 'watch_threads', 3)
#5 /home/mywebsite/prod/library/XenForo/Model/Deferred.php(252): XenForo_Deferred_TemplatePartialCompile->execute(Array, Array, 9.904307127, 'Reconstruction....')
#6 /home/mywebsite/prod/library/XenForo/Model/Deferred.php(378): XenForo_Model_Deferred->runDeferred(Array, 9.904307127, 'Reconstruction....', false)
#7 /home/mywebsite/prod/library/XenForo/Model/Deferred.php(331): XenForo_Model_Deferred->_runInternal(Array, 9.90430808067, 'Reconstruction....', false)
#8 /home/mywebsite/prod/library/XenForo/ViewRenderer/Abstract.php(352): XenForo_Model_Deferred->run(true, 9.90430808067)
#9 /home/mywebsite/prod/library/XenForo/ViewRenderer/Json.php(147): XenForo_ViewRenderer_Abstract::hasManualDeferredToRun()
#10 /home/mywebsite/prod/library/XenForo/ViewRenderer/Json.php(185): XenForo_ViewRenderer_Json::_addDefaultParams(Array)
#11 /home/mywebsite/prod/library/XenForo/ViewRenderer/Json.php(37): XenForo_ViewRenderer_Json::jsonEncodeForOutput(Array)
#12 /home/mywebsite/prod/library/XenForo/FrontController.php(593): XenForo_ViewRenderer_Json->renderRedirect(4, 'http://prod.ani...', NULL, Array)
#13 /home/mywebsite/prod/library/XenForo/FrontController.php(158): XenForo_FrontController->renderView(Object(XenForo_ControllerResponse_Redirect), Object(XenForo_ViewRenderer_Json), Array)
#14 /home/mywebsite/prod/admin.php(13): XenForo_FrontController->run()
#15 {main}

Etat de la requête

array(3) {
["url"] => string(48) "http://prod.mywebsite.net/admin.php?add-ons/toggle"
["_GET"] => array(1) {
["add-ons/toggle"] => string(0) ""
}
["_POST"] => array(6) {
["exists"] => array(23) {
["Waindigo_AlPag"] => string(1) "1"
["BBM"] => string(1) "1"
["Sedo_AdvBBcodeBar"] => string(1) "1"
["Calendar"] => string(1) "1"
["dpBetterAnalytics"] => string(1) "1"
["EnableDebugFromAdminHome"] => string(1) "1"
["Waindigo_LastPostAvatar"] => string(1) "1"
["Waindigo_MembersList"] => string(1) "1"
["MetaMirror"] => string(1) "1"
["WhoHasVisited"] => string(1) "1"
["ResetPasswordFromACP"] => string(1) "1"
["cemzoo_sitemap"] => string(1) "1"
["FilterTemplatesByAddOn"] => string(1) "1"
["Waindigo_ThreadThumbnails"] => string(1) "1"
["ThreadTitleInFirstPost"] => string(1) "1"
["sedo_tinymce_quattro"] => string(1) "1"
["XenGallery"] => string(1) "1"
["XenLoginSecurity"] => string(1) "1"
["widget_framework"] => string(1) "1"
["SimplePortal"] => string(1) "1"
["NFLJ_Showcase"] => string(1) "1"
["XenKingDir"] => string(1) "1"
["XMPromotedContent"] => string(1) "1"
}
["id"] => array(20) {
["Waindigo_AlPag"] => string(1) "1"
["Calendar"] => string(1) "1"
["dpBetterAnalytics"] => string(1) "1"
["EnableDebugFromAdminHome"] => string(1) "1"
["Waindigo_LastPostAvatar"] => string(1) "1"
["Waindigo_MembersList"] => string(1) "1"
["MetaMirror"] => string(1) "1"
["WhoHasVisited"] => string(1) "1"
["ResetPasswordFromACP"] => string(1) "1"
["cemzoo_sitemap"] => string(1) "1"
["FilterTemplatesByAddOn"] => string(1) "1"
["Waindigo_ThreadThumbnails"] => string(1) "1"
["ThreadTitleInFirstPost"] => string(1) "1"
["sedo_tinymce_quattro"] => string(1) "1"
["XenGallery"] => string(1) "1"
["XenLoginSecurity"] => string(1) "1"
["widget_framework"] => string(1) "1"
["SimplePortal"] => string(1) "1"
["NFLJ_Showcase"] => string(1) "1"
["XMPromotedContent"] => string(1) "1"
}
["_xfToken"] => string(8) "********"
["_xfRequestUri"] => string(10) "/admin.php"
["_xfNoRedirect"] => string(1) "1"
["_xfResponseType"] => string(4) "json"
}
}
 

Brogan

XenForo moderator
Staff member
#3
For anyone else encountering the issue in the future, can you post what you did to resolve it?