1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Custom Header Logo

Discussion in 'XenForo Questions and Support' started by kuyenmotdivad, Oct 6, 2010.

  1. kuyenmotdivad

    kuyenmotdivad Active Member

    Hi,

    I have tried adding a custom logo on my website but it does not show right - it's dimensions are 465 x 100 and you can see it here but its not showing right it's to small.
    Thanks for any help.​
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

    Don't you have to adjust the logo settings in the ACP?
     
  3. Russ

    Russ Well-Known Member

    Dave browse too:

    Appearance -> Styles Properties -> Header and Navigation

    Make sure your style is selected above all the settings and you can choose the logo dimensions there.

    I hope this helps!
     
    Brandon Sheley and Blandt like this.
  4. Brogan

    Brogan XenForo Moderator Staff Member

    Moved to support forum :)
     
  5. Maria

    Maria Member

    I had this problem too, and editing the values in the "Header and Navigation" preferences didn't seem to work. I had to edit the header.css template and find this:

    Code:
    height: 35px;
    and remove it.

    I imagine that in future releases you probably won't need to do this.
     
  6. Brogan

    Brogan XenForo Moderator Staff Member

    The dev's did say that the style properties system isn't quite complete so that may be part of it.

    Due to unforseen circumstances, we have been unable to move portions of the CSS that drives the XenForo style into the Style Properties system as planned. However, this task is near the top of our priority list and we expect the style to be fully propertised in the next beta release, which we will make in the coming days.
     
  7. Kim

    Kim Well-Known Member


    Thank you Maria :)
     
  8. kuyenmotdivad

    kuyenmotdivad Active Member

    That did it, Thanks Maria. :)
     
  9. Ruven

    Ruven Well-Known Member

    I dont know if removing it is a good idea, i mean its there for a reason right, it might have other uses?
    I just bumped it up to 90 and it worked great.
     
  10. Kier

    Kier XenForo Developer Staff Member

    You can remove it, provided you make sure that your logo image is shorter than the value specified for the logo height style property.
     
  11. erich37

    erich37 Well-Known Member

    do I need to creat my own style (child theme) in order to change my logo ?
    do I need to create a child-theme so that my custom logo remains at my website when doing upgrades ?

    I just want to change the XF-logo to my custom logo now, not sure how to do this......
    I do not want to change any other styles, just changing the logo-image
     
  12. Kier

    Kier XenForo Developer Staff Member

    There is no need to create another style, just edit the default style - changes you make to this will survive updates.
     
    erich37 likes this.
  13. erich37

    erich37 Well-Known Member

    do I need to save my custom logo in the same path:
    styles/default/xenforo/logo.png

    or can I create a new folder for the logo-path ?
    I do not want to have "xenforo" within my logo-path.

    thanks,
     
    Maxxamillion likes this.
  14. Robert F Schmitz

    Robert F Schmitz Well-Known Member

    Helpful, thanks.
     
  15. MrBrian

    MrBrian Active Member

    You can place it under any directory as you wish to as long as you fill in the location of your logo Image path correctly. You can even create a new directory just for the logo itself. It's all up to your own wish. ;)
     
  16. erich37

    erich37 Well-Known Member

    my logo-size is 450px by 60px.

    however it does not show its full size, but is much smaller.

    not sure where can I set the width of the logo in ACP ?
     
  17. MrBrian

    MrBrian Active Member

    It's located at the same page as where you set your logo image path.

    You need to change the default value to the actual value of your own logo.
     
  18. erich37

    erich37 Well-Known Member

    Sorry, I can not find this of where to change the settings for the image-width.

    It only says:
    "Header Logo Image Path"
    "Height of Header Logo"
    "Header Tab Height"
     
  19. Kim

    Kim Well-Known Member


    Hi Erich, you need to follow these instructions to adjust or edit out the height attribute in the header.css file...

    Styles & Templates/ Templates/header.css

    find this class...

    #logo img
    {
    vertical-align: middle;
    /*height: 35px;*/
    }


    and either adjust the height to your logo size, or as I have done.. comment it out.

    :)
     
    anotheralias and Tim like this.
  20. erich37

    erich37 Well-Known Member

    thanks Dragonfly, that worked.
    I just figured I do not need to mess with files on my FTP, just changing this within the ACP.
     

Share This Page