• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.
Contact Us Essentials

Contact Us Essentials [Paid] 1.3.4

No permission to buy (£20.00)

Stuart Wright

Well-known member
#1
Stuart Wright submitted a new resource:

Contact Us Essentials - Supercharge your Contact Us link with essential extra functionality

This addon enhances the Contact Us feature of Xenforo by giving admin several essential new options. We've been using it on AVForums.com for years.

It’s based around setting up Recipient Groups. Each recipient group has a title which is the name of the recipients (for example, Forum Admin, Site Feedback, Advertising Team). This is shown in the Contact Us form, and prompts users to choose who to send their enquiry to.

View attachment 138090

In the...
Read more about this resource...
 

Stuart Wright

Well-known member
#2
If anyone wants to use this on a version of Xenforo prior to 1.5, please contact me privately. It will probably work on earlier versions, but I can't guarantee it, so we can look at testing it, and if it works, you may then purchase a license.
 
#4
Hey Stewart...Long time. See you are doing well. Brenda and I are just living the good life. :)

Hey...I just bought this add-on for Contact Us and installed it. However, even after setting it up, when I click Contact Us the site says the page can not be found. I do have it set like you had shown. (see attached)


The following error occurred:
Not Found
The requested URL /community/contact-us was not found on this server.


So kind of not having any luck with this simple install.

(Testing on DBSTalk.com and also is needed for TiVoCommunity.com)
 

Attachments

Stuart Wright

Well-known member
#5
Hey Stewart...Long time. See you are doing well. Brenda and I are just living the good life. :)

Hey...I just bought this add-on for Contact Us and installed it. However, even after setting it up, when I click Contact Us the site says the page can not be found. I do have it set like you had shown. (see attached)


The following error occurred:
Not Found
The requested URL /community/contact-us was not found on this server.


So kind of not having any luck with this simple install.

(Testing on DBSTalk.com and also is needed for TiVoCommunity.com)
Hi David, hope you are well and great to see you involved with Xenforo.
Did you set up your recipient groups?
Do you have any other routes set up which might interfere with the contact-us route?
 
#13
So you want to alert the people who have sent the form? Why would you want to do that?
I want Departments will get an automated PC alert.

Please can you update To text to Departments ? Does have option the email also will be sent to the default contact email address?

Example:

 
Last edited:
#14
@Stuart Wright this is bug add-on, Cannot use this add-on because its not sending one copy to default contact email address. One more bug. This add-on are not use Default Email Address from sending, Its used Contact Email Address from sending. Disabled this add-on but still its doing Redirects to /contact-us after completed the send. Please do fix this both bug issue.

Code:
My "Default Email Address" is "info@mysite.com" and "Contact Email Address" is "support@mysite.com" , Disabled this add-on but still using : from "support@mysite.com" → To "support@mysite.com" in Contact Us form.
 
Last edited:

Stuart Wright

Well-known member
#15
I want Departments will get an automated PC alert.

Please can you update To text to Departments ? Does have option the email also will be sent to the default contact email address?

Example:

Can you not simply change the phrase to read 'Departments'? And no, there is no option to send to the default email address. It's simple enough to set up the recipients.

@Stuart Wright this is bug add-on, Cannot use this add-on because its not sending one copy to default contact email address. One more bug. This add-on are not use Default Email Address from sending, Its used Contact Email Address from sending. Disabled this add-on but still its doing Redirects to /contact-us after completed the send. Please do fix this both bug issue.

Code:
My "Default Email Address" is "info@mysite.com" and "Contact Email Address" is "support@mysite.com" , Disabled this add-on but still using : from "support@mysite.com" → To "support@mysite.com" in Contact Us form.
I disagree that there are bugs with this addon. We have been using it fine at AVForums.com for years. And when sending the email, it uses either the email address which the non-member enters, or the email address in the member's profile.
Can you supply more information about the redirect after the addon is disabled?
 
#16
Can you not simply change the phrase to read 'Departments'? And no, there is no option to send to the default email address. It's simple enough to set up the recipients.


I disagree that there are bugs with this addon. We have been using it fine at AVForums.com for years. And when sending the email, it uses either the email address which the non-member enters, or the email address in the member's profile.
Can you supply more information about the redirect after the addon is disabled?
What Email Address used by xenforo from sending? xenforo used Default Email Address from send but your add-on used Contact Email Address from send. Disabled this add-on but still are used Contact Email Address from send to Recipient. Uninstalled then this issue fixed.




Disabled this add-on but still its doing Redirects to /contact-us after completed the send from Default URL /misc/contact)
 
Last edited:

Stuart Wright

Well-known member
#17
Please can you update To text to Departments ?
No, Xenforo uses phrases so people can change the text to what they want. I am happy with the current default text.
Does have option the email also will be sent to the default contact email address?
Sorry, no. Nobody else has asked for that functionality and we have never needed it. You can add any email address to the cc or bcc recipient of each of your contact groups.
This add-on are not use Default Email Address from sending, Its used Contact Email Address from sending.
This has been tested and uses the correct email address according to the setting at
admin.php?options/list/basicBoard#_defaultEmailAddress
Disabled this add-on but still its doing Redirects to /contact-us after completed the send. Please do fix this both bug issue.
If you disable this addon, you also have to go to
/admin.php?options/list/basicBoard#_contactUrl
where you have to reset the redirect URL.
 
#18
This has been tested and uses the correct email address according to the setting at
admin.php?options/list/basicBoard#_defaultEmailAddress
No, Its used admin.php?options/list/basicBoard#_contactEmailAddress from sending.

If you disable this addon, you also have to go to
/admin.php?options/list/basicBoard#_contactUrl
where you have to reset the redirect URL.
Yes, we do this reset the redirect URL but still are not fixed. Redirects to /contact-us after completed the send from Default URL /misc/contact. Do you checked out the PC Video demo?
 

Stuart Wright

Well-known member
#19
No, Its used admin.php?options/list/basicBoard#_contactEmailAddress from sending.

Yes, we do this reset the redirect URL but still are not fixed. Redirects to /contact-us after completed the send from Default URL /misc/contact. Do you checked out the PC Video demo?
Our experience is different, and we can't reproduce the problems you are reporting.
 
#20
Our experience is different, and we can't reproduce the problems you are reporting.
Are you understanding that what i am reporting? Who are development this add-on? Please let me show that how its working without the issue that what i am reporting. Please check out the PC demo and show me same demo from your side.