• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Chrome Does Not Open Link Properly, But FireFox Does

TheBigK

Well-known member
#1
I'm trying to include the 'Become A Member' button on my WordPress powered blog to redirect the users to XF powered community.

Code:
<label id="SignupButton" for="LoginControl">
<a class="inner" href="http://www.crazyengineers.com/community/register/">Become A Member!</a>
</label>
I've created a text widget and pasted above code in it. I've copied code from Xenforo CSS to bring the styling to the button. Now the problem is -

1. The button works fine in FireFox (latest, 14).
2. The When accessed from chrome, the page refreshes.

What am I doing wrong?
 

TheBigK

Well-known member
#4
I'm not sure, but it looks like plain HTML job to me. Plus, this thing works perfect in Firefox. Chrome's got issues.
 

TheBigK

Well-known member
#6
Ow!

Any suggestions on how to fix this? I want to display 'Become A Member' button XF style on WordPress. What changes should I make?
 

TheBigK

Well-known member
#8
Let me try it with a div. So it should be <div id="SignupButton" for="LoginControl">

and the CSS would look like -

#SignupButton { ...};

, am I right?
 

MagnusB

Well-known member
#9
Code:
<div id="SignupButton">
  <a href="#" class="inner">Become a member now!</a>
</div>
The CSS should start like that, yes.

The for in label identifies what the label is for, for example for="radio1" means it is the label for the form element with id="radio1".
 

MagnusB

Well-known member
#13
It usually don't unless it is a javascript or css conflict. Same version as me though different OS, but that really shouldn't matter. Have you tested it on Safari?
 

MagnusB

Well-known member
#15
Well, I am stomped. I can't see why it shouldn't work for you. The only thing I could think of was different between me and you is the cache.
 

TheBigK

Well-known member
#16
I asked few random people on the Earth who use chrome and they say it's working fine :)

@MagnusB : Really appreciate your help. Thanks a TON! (y)
 
#18
There are times when clearing the cache in Chrome and Firefox can still produce errors. I cleared cached, and then performed a SHUT DOWN on my PC, and everything worked in both browsers