1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Child Node Not Viewable

Discussion in 'Troubleshooting and Problems' started by DocSkittles, Jun 20, 2012.

  1. DocSkittles

    DocSkittles Member

    Hi everyone,

    I have a child node that is not viewable. It is not marked as private and it's permissions are inherited from the parent/category node. The inherited permissions are the same in the categories other child nodes, but this is the only one not visible.

    I'm running 1.1.3 and have checked it in both Safari and FireFox. I've also looked at the various groups permissions and they all seem to be set the same. I turned off all of add-ons, but no change there.

    Does anyone have an idea as to what may be causing it?

    On a side note, this node along with another are not visible in Tapatalk either.


    Thanks in advance!
     
  2. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Maybe this:

    Admin CP -> Applications -> Display Node Tree -> [click the node] -> Display in the node list
     
  3. DocSkittles

    DocSkittles Member

    No, I had that checked. I fixed it by doing a work around. I created a new child node with a similar name, moved the threads in the nodes causing problems, and then deleted the old nodes that were causing issues. All fixed. Thanks for the help!
     
  4. Main Company

    Main Company Active Member

    I'm now having a similar issue.

    I've created quite a number of child nodes, but this is the first one that's five levels deep, and I am unable to view it. When I move the child node to the 4th level, I can view it.

    Is there a setting that limits the number of child levels? I can't seem to figure out why it is NOT viewable when it's a 5th-level child, but is viewable when it is a 4th-level child.

    Any thoughts?
     
  5. Mike

    Mike XenForo Developer Staff Member

    There are no depth limits like that out of the box, though you might have to go into a parent to be able to see a deep child node. Can you provide the URL to view the forum you can't see?
     
  6. Main Company

    Main Company Active Member

    The forum is behind a company firewall, so i am sorry that I cannot provide access.

    Additionally, after further research, I believe the issue is with the Addon Nodes as Tabs, as I have been unable to view the 5th level node on my tab navigation. So, in hindsight, I should probably post this issue in the Nodes as Tabs resource discussion.
     
  7. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    The Nodes As Tabs addon does have a depth setting for secondary nav links. When editing the node, look for the Depth Of Child Links setting.
     
    Main Company likes this.
  8. Main Company

    Main Company Active Member

    That worked. I had to change from 2 to 3. Thx
     

Share This Page