1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.1 Can't log on ACP

Discussion in 'Troubleshooting and Problems' started by SmauG, Aug 17, 2012.

  1. SmauG

    SmauG Member

    Don't really know what happended. Yesterday was working fine and i didn't modified anything on last week, but now doesn't log in.

    I can enter on ACP login page, put my info and try to log and it just shows an orange M below the login form. And doesn't matters if i put info or not, just clicking on login button shows it. I've tried to re-upload the controllerAdmin but doesn't solve anything.

    Anyone who can help? :)
  2. SmauG

    SmauG Member

    Sorry, nevermind. You can delete the post as indeed i've made a small change yesterday. Reverted and working :)
  3. Chris D

    Chris D XenForo Developer Staff Member

    An orange M below the login form? Not heard of that before. Can you upload a screenshot?

    I've seen people have problems logging in after enabling a caching solution such as APC. Have you done anything like that, at all?

    You may also want to try rebuilding the master data, if you're able to. Just go to http://www.yourforum.com/install

    It will say there are no versions to upgrade, but contain a link that allows you to Rebuild Master Data.

    This should not cause the loss of any data.

    Glad you got it sorted :)

    For future reference, what was the orange M, and what caused this issue?
  4. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Is there a specific error? Normally a failed admin login is either a lack of admin rights or an incorrect password, both of which return errors to that effect.

    It's possible an addon is interfering. Try adding this line to your library/config.php file to disable addons:

    $config['enableListeners'] = 0;
    If the problem is affecting all logins (including on the front end) then see this post for some things to check:


    edit - i'm too slow :eek:
    Chris D likes this.
  5. SmauG

    SmauG Member

    I've been editing the user model to add more data from more tables to $user, adding a left join on the request (by name, email, ...). I'll check it later to exactly know why it failed because i've just reverted it to be able to log in on the ACP, but will change it later to be able to pick my data :)
    It also made crash front end login (as i was logged, didn't figured it out until tried) and after seeing the error i remembered the change.

Share This Page