• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Not a bug  BBCode inside CODE

James

Well-known member
#1
Code:
[SIZE=10pt][FONT=Consolas]<script type="text/javascript">      var _gaq = _gaq || [];    _gaq.push(['_setAccount', 'UA-10855523-4']);    _gaq.push(['_trackPageview']);     (function() {    var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;    ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);    })();   </script>[/FONT][/SIZE]
[SIZE=10pt][FONT=Consolas]
[/FONT][/SIZE]
[SIZE=10pt]When using CODE BBCodes, BBCode is automatically inserted inside the code tags? (see above).[/SIZE]
 

Vincent

Well-known member
#2
Code:
[B]Is it true?[/B] Yes

[plain][b]Let's see what happens if we wrap this in plain text...[/b][/plain] Nothing...
I can reproduce it :)
 

James

Well-known member
#3
Code:
Just another random test
EDIT: Seems to work fine here... yet when I put the above code into CODE BBCodes, it automatically added the BBCodes ([SIZE][FONT]) itself.
My two cents on this is that it's the indenting or possible conflictions inside the code itself.
 

James

Well-known member
#9
Code:
[SIZE=10pt][FONT=Consolas]<script type="text/javascript">      var _gaq = _gaq || [];    _gaq.push(['_setAccount', 'UA-10855523-4']);    _gaq.push(['_trackPageview']);     (function() {    var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;    ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);    })();   </script>
[/FONT][/SIZE]

Nop it's not fixed :p
 
#10
Code:
[SIZE=10pt]<script type="text/javascript">      var _gaq = _gaq || [];    _gaq.push(['_setAccount', 'UA-10855523-4']);    _gaq.push(['_trackPageview']);     (function() {    var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;    ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);    })();   </script>[/SIZE]
[SIZE=10pt]
[/SIZE]
[SIZE=10pt][/size]
 

James

Well-known member
#11
Code:
[/SIZE][/FONT][/SIZE][/SIZE][/FONT][/SIZE][/SIZE][/FONT][/SIZE][/SIZE][/FONT][/SIZE]
[FONT=Consolas][FONT=Consolas][FONT=Consolas][SIZE=10pt][FONT=Consolas]<script type="text/javascript">      var _gaq = _gaq || [];    _gaq.push(['_setAccount', 'UA-10855523-4']);    _gaq.push(['_trackPageview']);     (function() {    var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;    ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);    })();   </script>
[/CODE]
[/FONT][/SIZE][/CODE][/FONT][/FONT][/FONT]

Still fails for me :([/CODE][/SIZE][/SIZE][/CODE][/FONT]
Now it's putting my reply in code tags ;o odd[/CODE][/SIZE][/FONT][/SIZE]
 
#12
Code:
[/SIZE][/FONT][/SIZE][/SIZE][/FONT][/SIZE][/SIZE][/FONT][/SIZE]
[SIZE=10pt]<script type="text/javascript">      var _gaq = _gaq || [];    _gaq.push(['_setAccount', 'UA-10855523-4']);    _gaq.push(['_trackPageview']);     (function() {    var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;    ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);    })();   </script>[/SIZE]
[SIZE=10pt][/SIZE][/CODE][/SIZE][/SIZE][/CODE][/FONT]

Still fails for me :([/CODE][/SIZE][/SIZE][/CODE][/FONT]
Now it's putting my reply in code tags ;o odd[/CODE][/SIZE][/FONT][/SIZE]
[/code]
[/SIZE][/FONT][/SIZE]
 
#13
Code:
[/SIZE][/FONT][/SIZE][/SIZE][/FONT][/SIZE][/SIZE][/FONT][/SIZE]
[SIZE=10pt]<script type="text/javascript">      var _gaq = _gaq || [];    _gaq.push(['_setAccount', 'UA-10855523-4']);    _gaq.push(['_trackPageview']);     (function() {    var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;    ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);    })();   </script>[/SIZE]
[SIZE=10pt][/SIZE][/CODE][/SIZE][/SIZE][/CODE][/FONT]

Still fails for me :([/CODE][/SIZE][/SIZE][/CODE][/FONT]
Now it's putting my reply in code tags ;o odd[/CODE][/SIZE][/FONT][/SIZE]
[/SIZE][/FONT][/SIZE]
[/code]
 

Vincent

Well-known member
#14
I was just about to report this again, than I noticed there was already a topic like this.

I got a questions for the devs, because I think this is the WYSIWIG editor's fault.
Or is it xenForo?