• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

awaiting email confirmation doesn't work for gmail email account

#1
Dear Sir,

We found for all the user that register using the gmail account had the awaiting email confirmation status.
When we confirm to them, they said they didn't received any email confirmation.
Please adivise

Thanks,
Irawan
 

Chris D

XenForo developer
Staff member
#5
We had the same problem. No matter what we tried, the mails kept going to the spam folder.

The way we got around this was we use Google Apps for our e-mail addresses. If you do this, then you can actually set your XenForo SMTP server as smtp.gmail.com.
 
#7
I am having a issue - No one is getting confirmation email. it is not going in the spam filter. If you have it resend still nothing. I have a ton of people complaining and we tested it ourselves.
Does anyone have an idea why it would do this?
 

whyweprotest

Well-known member
#9
I am having a issue - No one is getting confirmation email. it is not going in the spam filter. If you have it resend still nothing. I have a ton of people complaining and we tested it ourselves.
Does anyone have an idea why it would do this?
You need to check in your email logs, every destination provider responds with an error message, could be spf failure, being throtled, blacklisted host or network, lack of ptr etc. You will need to signup for aol and microsoft email partner programs and provide them with an abuse handle contact.

Email is a B*tch to maintain, I hate it. Good luck.
 

Jake Bunce

XenForo moderator
Staff member
#11
whyweprotest is correct. You need to check your mail logs on your server to confirm delivery or to discover the reason why it was not delivered. Or you can just try a different mail host. Here is a guide for using Google as your SMTP server:

http://xenforo.com/community/threads/setting-up-google-as-smtp-server-for-your-xenforo.6180/

Another thing is it is taking forever for the newest member to show up.. seems to have a 18 hour delay.
That statistic excludes users who haven't yet confirmed their email, so that is related to the email problem.
 
#12
Thanks for everyone's help. I will do just that. That does make sense Jake, however I did one with yahoo and it did send the confirmation but still did not show me as the newest member. I will play with it and see what I can do.