1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Avatar Issue, simply won't change.

Discussion in 'Troubleshooting and Problems' started by faeronsayn, Jun 15, 2012.

  1. faeronsayn

    faeronsayn Well-Known Member

    One of my site members just reported to me that uploading new avatars does not change the current ones. It simply keeps the current ones, and thus you cannot change avatars any longer. I checked this out and it is definitely confirmed true. You can't for some reason change avatars. I recently switched servers I am not sure if its because of that or not.

    Any help on this topic would be highly appreciated.
     
  2. Will

    Will Active Member

    Does this help?

    http://xenforo.com/community/threads/avatar-issues-on-new-server.32408/#post-370098
     
    faeronsayn likes this.
  3. faeronsayn

    faeronsayn Well-Known Member

  4. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Any specific errors? Anything in the log?

    Admin CP -> Tools -> Server Error Log

    Check the permissions for data and internal_data. Both directories and their contents need to be writable (chmod 777).

    Also, what image library are you using?

    Admin CP -> Home -> Options -> Attachments -> Default Image Processor

    Try a different library if available.
     
  5. faeronsayn

    faeronsayn Well-Known Member



    First of all, I just realized that when I update the avatar it seems to be updating at other places but just not in the preview section when I am changing it.

    One of my members pointed this out here.

    [​IMG]


    Secondly I actually looked at the server error logs and I am getting a couple errors such as "too many connections" from mysqli.

    Code:
    Too many connections
    29 minutes ago - library/Zend/Db/Adapter/Mysqli.php:333
    Delete...
    Too many connections
    34 minutes ago - library/Zend/Db/Adapter/Mysqli.php:333
    Delete...
    Lost connection to MySQL server at 'sending authentication information', system error: 32
    47 minutes ago - library/Zend/Db/Adapter/Mysqli.php:333
    Delete...
    Too many connections
    47 minutes ago - library/Zend/Db/Adapter/Mysqli.php:333
    Delete...
    Too many connections
    50 minutes ago - library/Zend/Db/Adapter/Mysqli.php:333
    Delete...
    Too many connections
    51 minutes ago - library/Zend/Db/Adapter/Mysqli.php:333
    Delete...
    Too many connections
    51 minutes ago - library/Zend/Db/Adapter/Mysqli.php:333
    Delete...
    Lost connection to MySQL server at 'sending authentication information', system error: 32
    56 minutes ago - library/Zend/Db/Adapter/Mysqli.php:333
    Delete...
    Lost connection to MySQL server at 'sending authentication information', system error: 32
    58 minutes ago - library/Zend/Db/Adapter/Mysqli.php:333
    Delete...
    Lost connection to MySQL server at 'sending authentication information', system error: 32
    58 minutes ago - library/Zend/Db/Adapter/Mysqli.php:333
    Delete...
    Lost connection to MySQL server at 'sending authentication information', system error: 32
    58 minutes ago - library/Zend/Db/Adapter/Mysqli.php:333
    Delete...
    Lost connection to MySQL server at 'sending authentication information', system error: 32
    58 minutes ago - library/Zend/Db/Adapter/Mysqli.php:333
    Delete...
    Lost connection to MySQL server at 'sending authentication information', system error: 32
    58 minutes ago - library/Zend/Db/Adapter/Mysqli.php:333
    Delete...
    Lost connection to MySQL server at 'sending authentication information', system error: 32
    58 minutes ago - library/Zend/Db/Adapter/Mysqli.php:333
    Delete...
    Lost connection to MySQL server at 'sending authentication information', system error: 32
    58 minutes ago - library/Zend/Db/Adapter/Mysqli.php:333
    Delete...
    Lost connection to MySQL server at 'sending authentication information', system error: 32
    58 minutes ago - library/Zend/Db/Adapter/Mysqli.php:333
    Delete...
    Lost connection to MySQL server at 'sending authentication information', system error: 32
    58 minutes ago - library/Zend/Db/Adapter/Mysqli.php:333
    Delete...
    Lost connection to MySQL server at 'sending authentication information', system error: 32
    58 minutes ago - library/Zend/Db/Adapter/Mysqli.php:333
    Delete...
    Lost connection to MySQL server at 'sending authentication information', system error: 32
    58 minutes ago - library/Zend/Db/Adapter/Mysqli.php:333
    Delete...
    Lost connection to MySQL server at 'sending authentication information', system error: 32
    58 minutes ago - library/Zend/Db/Adapter/Mysqli.php:333
    
    As for the change libraries, I only have one installed, and since I am using plesk (just started) I have no idea on how to install / rebuild apache.
     
  6. craigiri

    craigiri Well-Known Member

    I think this all may be related to your server (as per your other thread).
     
  7. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    That error is caused by one of these MySQL settings being exceeded:

    wait_timeout
    max_allowed_packet

    Your host or server person needs to increase these settings in MySQL. There is more info here:

    http://dev.mysql.com/doc/refman/5.1/en/gone-away.html

    That error is caused by this MySQL setting being exceeded:

    max_connections

    Your host or server person needs to increase this setting in MySQL. There is more info here:

    https://dev.mysql.com/doc/refman/5.5/en/too-many-connections.html

    That might be a javascript problem or a problem with an addon. Try disabling any addons to see if that affects it.
     

Share This Page