1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

APC - General questions

Discussion in 'Server Configuration and Hosting' started by ChemicalKicks, Dec 4, 2011.

  1. ChemicalKicks

    ChemicalKicks Well-Known Member

    Would love some insight to the following questions.

    As far as I'm aware I have APC enabled as per this.

    Untitled.png

    I haven't played about with configuring APC yet, is this something I should do or are defaults fine?
     
  2. Slavik

    Slavik XenForo Moderator Staff Member

    How large is your site?
     
  3. Luke F

    Luke F Well-Known Member

    Your apc is quite out of date
     
  4. ChemicalKicks

    ChemicalKicks Well-Known Member

    Half a million posts. DB is about 350Mb and got about a GB of attachments. :)
     
  5. Slavik

    Slavik XenForo Moderator Staff Member

    Users / passing trafic?
     
  6. ChemicalKicks

    ChemicalKicks Well-Known Member

    How should I update it?
     
  7. ChemicalKicks

    ChemicalKicks Well-Known Member

    700 odd registered, usually about 10 logged in and 50 guests.
     
  8. Slavik

    Slavik XenForo Moderator Staff Member

    You wont gain much via optimisation, id just leave it be.
     
    Darkimmortal and ChemicalKicks like this.
  9. ChemicalKicks

    ChemicalKicks Well-Known Member

    Will do :)

    What about what DM said about the version, how do I update it?
     
  10. Slavik

    Slavik XenForo Moderator Staff Member

    sudo pecl upgrade apc
     
    ChemicalKicks likes this.
  11. ChemicalKicks

    ChemicalKicks Well-Known Member

    Thank you, one last thing, after running through the upgrade I get the following

    Code:
    upgrade ok: channel://pecl.php.net/APC-3.1.9
    configuration option "php_ini" is not set to php.ini location
    You should add "extension=apc.so" to php.ini
    Where abouts in the php.ini do I add that? Do I need to do it?
     
  12. Slavik

    Slavik XenForo Moderator Staff Member

    the default install looks for the php.ini in a set location, depending on your install it may not be at that location.

    just load up your phpinfo and see if the upgrade has gone through there

    (you need to restart httpd first obviously)
     
    ChemicalKicks likes this.
  13. ChemicalKicks

    ChemicalKicks Well-Known Member

    Yeah upgrade has gone through, just thought it might not be working right without the line in the php.ini, I'm running php5-fpm & nginx
     
  14. Slavik

    Slavik XenForo Moderator Staff Member

    all done then :)
     
    ChemicalKicks likes this.

Share This Page