1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

An unexpected error occurred. Please try again later.

Discussion in 'Troubleshooting and Problems' started by Uniphix, Nov 2, 2011.

  1. Uniphix

    Uniphix Active Member

    Hello I keep getting this "An unexpected error occurred. Please try again later." on my site, I am not sure WHY. I have fully forced debug = true on etc. I cannot access any of the index pages but I can access a phpinfo file that I made on the server.

    I am using PHP 5.3 and MySQL 5.5.17. I am not sure why its not working...
     
  2. Uniphix

    Uniphix Active Member

    I also have connected to the database, there is also no xf_error_log entries from the time I started this. There is also no apache2 errors, php5 errors OR even mysql errors so I am very very stomped right now at to what is wrong.
     
  3. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    View the source code of the error page. It should have a more detailed error.
     
  4. Uniphix

    Uniphix Active Member

    There is no source code, it is totally blank with just that message.
     
  5. mrGTB

    mrGTB Well-Known Member

    I've started getting these error messages popping up once again, they are listed there in the Admin CP error logs, but no error log file is generated on the server itself looking with FTP. It seems to happen also when the site is running very slow (server issues), like they are getting generated through server "time-outs". If the site is running as normal they don't appear in the logs at all.

    So right now I'm putting it down to my server running crappy at times.

    I'm using:

    PHP 5.3.8
    MySQL 5.1.46
    Apaxhe 2.2.11
     
  6. Uniphix

    Uniphix Active Member

    Yeah but the problem is I don't get any error logs within the admin cp logs. I can't even access that page...
     
  7. Brogan

    Brogan XenForo Moderator Staff Member

    Is it constant or intermittent?

    If intermittent then it would suggest some sort of server issue.
     
  8. Uniphix

    Uniphix Active Member

    It is constant only page I can actually access is my phpinfo within the same directory. Is there something that I am may be missing from this setup I have for XenForo...???
     
  9. mrGTB

    mrGTB Well-Known Member

    That's a different problem then your having there.
     
  10. Brogan

    Brogan XenForo Moderator Staff Member

    If it's constant then that would indicate a problem with the database and/or server files.

    Have any changes been made since it was last working, by you or the host?

    Is the database present and viable?

    Try uploading the files from the .zip package again to rule out any issues there.
     
  11. Uniphix

    Uniphix Active Member

    I think I may have found what I did wrong. I was renaming the database which ended up changing a bunch of other stuff in the sql script I was uploading (Restoring) so I think I am going to attempt to fix those errors and try again
     
  12. Uniphix

    Uniphix Active Member

    Nope that was not it :(
     
  13. Uniphix

    Uniphix Active Member

    Our host is Rackspace, I setup the linux etc. all myself, and php basically installing LAMP. So I am not sure what else I am missing...
     
  14. Uniphix

    Uniphix Active Member

  15. Brogan

    Brogan XenForo Moderator Staff Member

    Is this a brand new install now you're trying?

    Perhaps you should consider raising a ticket but it may be due to your home-rolled server configuration.
     
  16. mrGTB

    mrGTB Well-Known Member

    Are error logs displayed in the Admin CP written to the database or a (file stored on the server)? The reason I ask, is because you said you cannot even access that page. That sounded like a Folder or File "Chmod" permission denied problem (maybe).
     
  17. Uniphix

    Uniphix Active Member

    Thanks Brogan your da man!
     

Share This Page