1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

An unexpected database error occurred. Please try again later.

Discussion in 'Installation, Upgrade, and Import Support' started by Adam Wakefield, Jul 26, 2011.

  1. This error pops up now and then (on a white page)
    An unexpected database error occurred. Please try again later.

    Here are the details in the Admin error logs:

    Message - Can't connect to MySQL server on 'mysql1092.servage.net' (110)
    File - library/Zend/Db/Adapter/Mysqli.php:333

    Details:
    Code:
    Error Info
    Zend_Db_Adapter_Mysqli_Exception: Can't connect to MySQL server on 'mysql1092.servage.net' (110) - library/Zend/Db/Adapter/Mysqli.php:333
    Generated By: Unknown Account, 2 minutes ago
    Stack Trace
    #0 /mounted-storage/home71a/sub001/sc11532-WPTM/www/library/Zend/Db/Adapter/Abstract.php(315): Zend_Db_Adapter_Mysqli->_connect()
    #1 /mounted-storage/home71a/sub001/sc11532-WPTM/www/library/XenForo/Application.php(547): Zend_Db_Adapter_Abstract->getConnection()
    #2 [internal function]: XenForo_Application->loadDb(Object(Zend_Config))
    #3 /mounted-storage/home71a/sub001/sc11532-WPTM/www/library/XenForo/Application.php(774): call_user_func_array(Array, Array)
    #4 /mounted-storage/home71a/sub001/sc11532-WPTM/www/library/XenForo/Application.php(804): XenForo_Application->lazyLoad('db', NULL)
    #5 /mounted-storage/home71a/sub001/sc11532-WPTM/www/library/XenForo/Model.php(161): XenForo_Application::get('db')
    #6 /mounted-storage/home71a/sub001/sc11532-WPTM/www/library/XenForo/Model/DataRegistry.php(138): XenForo_Model->_getDb()
    #7 /mounted-storage/home71a/sub001/sc11532-WPTM/www/library/XenForo/Model/DataRegistry.php(97): XenForo_Model_DataRegistry->_getMultiFromDb(Array)
    #8 /mounted-storage/home71a/sub001/sc11532-WPTM/www/library/XenForo/Dependencies/Abstract.php(134): XenForo_Model_DataRegistry->getMulti(Array)
    #9 /mounted-storage/home71a/sub001/sc11532-WPTM/www/library/XenForo/FrontController.php(125): XenForo_Dependencies_Abstract->preLoadData()
    #10 /mounted-storage/home71a/sub001/sc11532-WPTM/www/admin.php(13): XenForo_FrontController->run()
    #11 {main}
    Request State
    array(3) {
      ["url"] => string(52) "http://pnkllr.net/admin.php?logs/server-error&page=3"
      ["_GET"] => array(2) {
        ["logs/server-error"] => string(0) ""
        ["page"] => string(1) "3"
      }
      ["_POST"] => array(0) {
      }
    }
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

    That indicates a problem with the server - Can't connect to MySQL server on 'mysql1092.servage.net'

    You will need to speak to your host about that.
     
  3. Brogan

    Brogan XenForo Moderator Staff Member

    What were their reasons for telling you to create a new database?

    If the old DB was corrupt then importing the tables into the new one isn't going to help.
    Likewise if the old DB wasn't corrupt then creating a new DB was pointless.

    The error indicates a problem with (connecting to) the MySQL server, not the database.

    Are you sure your config.php settings are correct?
     
  4. Everytime i create a new DB it puts it on a new SQL server, for example:

    mysql1092.servage.net = Original (Can not connect to DP Error)
    mysql1078.servage.net = New (Server Error)
     

Share This Page