1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Fixed Allow to select multiple threads for moderation even when changing pages

Discussion in 'Resolved Bug Reports' started by gldtn, Dec 10, 2010.

  1. gldtn

    gldtn Well-Known Member

    You are able to select multiple threads for moderation in a forum on the page being viewed, but when you change page through the pagination on the discussion list it forgets the threads you have already selected on the previous page. Thus making you repeat boring action to moderate when you have a bunch of threads scattered throughout a forum section that needs moderation. Can we make xenforo remember our selections?

    Thanks!
     
  2. Mike

    Mike XenForo Developer Staff Member

    It does remember your selection from page to page. It stores it in a cookie.
     
  3. gldtn

    gldtn Well-Known Member

    Mike,

    It doesn't seem to be working on my forum. When I select a thread on 1 page and go to the other page and select another thread, it says I have only one thread selected and it only apply the action to the thread(s) selected on that page.
     
  4. Mike

    Mike XenForo Developer Staff Member

    As always, try on a default style. Additionally, you haven't changed any cookie settings via config.php have you?
     
  5. gldtn

    gldtn Well-Known Member

    I've just tried on a default style, but no go. The only settings on the config.php that I have is;

    Code:
    $config['cookie']['domain'] = '.plantasenteogenas.org'; 
     
  6. gldtn

    gldtn Well-Known Member

    Here is a couple of screenshots;

    Selecting 2 threads on first page;
    Screen shot 2010-12-13 at 3.28.16 PM.png

    Moving to the second page and selecting another thread;
    Screen shot 2010-12-13 at 3.28.36 PM.png
     
  7. Brogan

    Brogan XenForo Moderator Staff Member

    I just tested that here and it works fine.
    Do you have your cookie settings set quite high?
     
  8. gldtn

    gldtn Well-Known Member

    Is this a setting in the admin control panel? I was looking for this now and could find anything regarding the cookies on the admin side.

    The only line I have in for the config.php for cookies is the one I mentioned above.
     
  9. Brogan

    Brogan XenForo Moderator Staff Member

    I meant cookie settings with regards to your browser.
    As far as the inline mod tools are concerned, there's nothing to set up apart from the specific permissions.
     
  10. gldtn

    gldtn Well-Known Member

    Oh, no! My cookies settings on my browser is set to default. I even tried it with different browser to see if that would eliminate the problem, but still not working :/
     
  11. Brogan

    Brogan XenForo Moderator Staff Member

    Do you have a test moderator login so I could check?
     
  12. gldtn

    gldtn Well-Known Member

    I just ran a test on my localhost and it worked, so I went into my config.php from my live forum and removed the cookies config line that I mentioned above and it worked. Hmm.. now I'm wondering how I can get this to work with that line since I added that line for the wordpress bridge plugin to work correctly.
     
  13. Brogan

    Brogan XenForo Moderator Staff Member

    Yes, I just tested it also using the details you provided and it worked fine.

    I've moved this thread to general troubleshooting from suggestions now that we've confirmed the feature exists and does work.

    What happens with your WP installation if you remove the entry from config.php?
     
    gldtn likes this.
  14. gldtn

    gldtn Well-Known Member

    The login process when clicking to login under WP homepage tries to login into wordpress directly, where with the entry on the config.php it redirects to the board login page.
     
  15. Mike

    Mike XenForo Developer Staff Member

    I'm going to move this to bugs as there must be an issue with setting cookies with the custom domain via JS.
     
    Brogan and gldtn like this.
  16. Mike

    Mike XenForo Developer Staff Member

    I've fixed this now - there was a typo in the code ("coookie").
     
    gldtn and Dean like this.

Share This Page