• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

A few problems with Zend Server CE

Iestyn

Active member
#1
I've used MAMP for as long as I can remember, and decided to have a go at using Zend Server CE, but I've run into two small problems.

1. Does anyone know how to change the document root?
2. As you can see in the image below I keep getting the 'Failed to 'login':

CM Capture 2.png

Here are my config settings:

Hostnames: 127.0.0.1
Port: 10081

Can anyone point me in the right direction? Google search hasn't helped =[
 

Kier

XenForo Developer
Staff member
#3
Try changing the hostname from '127.0.0.1' to 'localhost' and ensure that the scheme is HTTP. It can be a bit funny sometimes.

All that said, Zend Controller (what you have there) is a bit of a waste of time, IMHO.
 

Iestyn

Active member
#4
Try changing the hostname from '127.0.0.1' to 'localhost' and ensure that the scheme is HTTP. It can be a bit funny sometimes.

All that said, Zend Controller (what you have there) is a bit of a waste of time, IMHO.
It still doesn't like it, i've changed the hostname to localhost, post 10081 and using http, but it doesn't like it, anymore ideas kier? :(

I'm also getting this error when using the zend stuff: http://xenforo.com/community/threads/irritating-mac-problem.13033/#post-171586

have you come across this problem before or know what i can do?
 

Iestyn

Active member
#6
Can you access http://localhost:10088 in your browser?
Yes I can, but I'm still getting the 'Unexpected response message' error. Any ideas? :(

CM Capture 1.png

1. I've also got two more questions, is it possible to remove the '10088' from the localhost url and add http in front of it?
2. How can I modify the the root folder? For example, make the 'Sites' folder the root so I can just drop stuff in there?

For the life of me I just can't get this working :-/

Thanks Kier.
 

Blandt

Well-known member
#7
I think you need to check your iptable (firewall ) ... not sure about how to go about doing that in Macs but it should be easy to figure out ...

2 . you are still using Apache, so to change your root folder you need to edit your default config file (again not sure where on mac but I would think under /home/zendserver/www or somewhere there :D)
 

Kier

XenForo Developer
Staff member
#8
Okay, a few things - Zend Server runs on several ports. The server itself runs on port 10081, while Apache runs (by default) on port 10088.

The correct settings for Zend Controller are:
Hostname: localhost
Port: 10081
Password: (whatever you set, make sure it's right!)​
Connection scheme: HTTP

If you want to change Apache to run on the default HTTP port (80) then you will need to do the following:
(Note that in these instructions, you should replace 'stormraven' with your OS X username.)

Open System Preferences > Sharing and make sure that Web Sharing is disabled.

Using the Terminal, run the following command:
sudo nano /usr/local/zend/apache2/conf.d/stormraven.conf

Within the new stormraven.conf file, enter the following configuration parameters:
Code:
Listen 80
HostnameLookups Off

User _www
Group staff

<Directory "/Users/stormraven/Sites/">
    Options Indexes MultiViews FollowSymLinks SymLinksIfOwnerMatch
    AllowOverride All
    Order allow,deny
    Allow from all
</Directory>

<VirtualHost *>
        ServerName stormraven
        DocumentRoot /Users/stormraven/Sites
</VirtualHost>
Save the file out (ctrl+x) and then restart apache with the following command:
sudo /usr/local/zend/apache2/bin/apachectl graceful

You should now be able to access your Zend webserver via http://stormraven/ and the document root will be the 'Sites' directory in your user profile.
 

Iestyn

Active member
#9
When I try to put the last sudo command in to restart apache it gives me a [failed] error:

http://dl.dropbox.com/u/18660955/kier.png

also it ads a .save to the stormraven.conf. am i doing something wrong? lol. (I've been up all night)

and no matter what i do i keep getting this:

'Failed to access Web server. Please make sure that the Web server is running and listening to the correct port'


I'm still relatively new to the mac so please forgive me.
 

Blandt

Well-known member
#10
Failed to connect because Apache is not running, you have an error in your conf file.

If I remember correctly ZendServer admin panel runs under lighttpd on port 10081. Navigate to http://localhost:10081 and see what you get ..

Post your Apache conf file
 

Iestyn

Active member
#11
Failed to connect because Apache is not running, you have an error in your conf file.

If I remember correctly ZendServer admin panel runs under lighttpd on port 10081. Navigate to http://localhost:10081 and see what you get ..

Post your Apache conf file
It just asks me to login, and when I do, it gives me this error 'Failed to access Web server. Please make sure that the Web server is running and listening to the correct port'.

Kier's post above has confused me even more too ^_^ i think i did everything right.
 

Kier

XenForo Developer
Staff member
#12
Right, but you keep trying to run Zend Controller, which is largely irrelevant to what we are trying to do here. Let's get the server up and running first, then worry about the silly Controller add-on (which does nothing of use, as far as I can see)
 

Blandt

Well-known member
#14
open up a shell window and do :
sudo nano /usr/local/zend/apache2/conf.d/stormraven.conf As Kier said ... when you get the screen ctrl-k all the way until you get rid of everything, copy Kier's text and edit your relevant name/domain etc ... Ctrl-x to save .. answer yes (Ctrl is Option on a mac I think)

then sudo /usr/local/zend/apache2/bin/apachectl start






PS: I have never seen a fresh install with more than say 30 - 40 lines in the config file .... hmmmm and your screenshot says you have an error on line 336 o_0 ... would you make a copy of that file and rename blah.txt and attach it here ... let me see that :)
 

Iestyn

Active member
#15
Run this:

sudo /usr/local/zend/bin/zendctl.sh start

And paste here the result.
Code:
httpd: Syntax error on line 376 of /usr/local/zend/apache2/conf/httpd.conf: Could not open configuration file /Users/iestynsinnett-jones/Server/conf/extra/httpd-autoindex.conf: No such file or directory
/usr/local/zend/bin/apachectl start [FAILED]
spawn-fcgi: socket is already in use, can't spawn
lighttpd watchdog is up and running.. [OK]
[ 11.03.2011 14:19:22 SYSTEM] watchdog for lighttpd is running.
[ 11.03.2011 14:19:22 SYSTEM] lighttpd is running.
Starting MySQL
 SUCCESS!
java_daemon watchdog is up and running.. [OK]
[ 11.03.2011 14:19:22 SYSTEM] watchdog for java_daemon is running.
[ 11.03.2011 14:19:22 SYSTEM] java_daemon is running.

Zend Server started...
iestyns-imac:~ iestynsinnett-jones$
That's what I'm getting. I'll give it another go now :)
 

Kier

XenForo Developer
Staff member
#16
If you can open your iMac to the internet and enable SSH access (Remote Login) I'll log in and get it running for you.
Screen shot 2011-03-11 at 14.45.05.png

If you want to do this, you'll need to direct port 22 on your firewall to forward to your iMac.
Screen shot 2011-03-11 at 14.46.37.png
 

Iestyn

Active member
#17
If you can open your iMac to the internet and enable SSH access (Remote Login) I'll log in and get it running for you.
View attachment 12337

If you want to do this, you'll need to direct port 22 on your firewall to forward to your iMac.
View attachment 12338
I've not done anything like this on a mac before, how can i get to the second screenshot you sent? i cant seem to find that anywhere, so i can enter the information in the second screenshot, please bare with me, im still learning the ropes when it comes to the mac, plus i haven't slept.
 

Kier

XenForo Developer
Staff member
#18
I've not done anything like this on a mac before, how can i get to the second screenshot you sent? i cant seem to find that anywhere, so i can enter the information in the second screenshot, please bare with me, im still learning the ropes when it comes to the mac, plus i haven't slept.
How do you connect to the Internet? Do you have a router over which you have control?
 

physicspirate

Well-known member
#19
I just want to append some additional information to this thread. I've been trying to get it setup as described in this thread but have had very little success. What I had to do to get Zend CE to work on my Mac was the following:

1. Remove zend CE via
Code:
sudo /usr/local/zend/bin/uninstall.sh
from what I read my many attempts at installing/reinstalling and following this guide didn't completely remove everything until I did that command
2. Run the Zend CE install package with everything default
3. Follow kiers steps in post #8
4. Create database via phpMyAdmin
5. Run xenforo install script

The only strange thing is that it all works at the following URL in my browser:

http://localhost/xenforo/

when I was expecting

http://physicspirate/xenforo

Even though I replaced stormraven with my current mac username in the apache config file. Either way at least it works and I can start building epic themes locally. Thanks for the info in this thread.
 

Shelley

Well-known member
#20
I can't seem to log into phpmyadmin using win7 64bit with zendserver 5.3 driving me absolutely nuts any help would be appreciated.

The php_error log is showing (below) if that helps

Code:
[29-May-2011 00:36:18] PHP Notice:  Undefined index:  Error_Handler in C:\Program Files (x86)\Zend\phpMyAdmin\libraries\Error_Handler.class.php on line 56
Capture.PNG

Edit: Ignore, I finally went with Xampp. Though I'm suspecting the issue I was having with phpmyadmin was a permission problem.