1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

2nd email PASSWORD RESET ( modify text/html layout? )

Discussion in 'XenForo Questions and Support' started by 1975, Dec 19, 2011.

  1. 1975

    1975 Member

    I receive the first lost password email and it works properly, however once reset it will send me this email below of which the username has a comma after it. Where can I edit this template to remove the comma?

    I've tried user_lost_password_reset in phrases but nothing changes in the email notification. Can anyone help?

    Note: I am not locked out, I am simply testing the reset password feature and would like to fix the email that users receive. Thank you in advance...
    ------------------------

    Domain.com Password Reset‏

    1975, your password at domain.com has been reset. You may log in using the password listed below.

    User Name: 1975,
    Password:
    xi9e9cc8

    Log in

    Thanks.
    domain.com
    ------------------------
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

    Moved to support.

    You will need to associate your forum account with your license to post in the customer forums.
     
  3. 1975

    1975 Member

    I have just associated my license with forum username. Thanks!
     
  4. Brogan

    Brogan XenForo Moderator Staff Member

    Try the user_lost_password_reset_body_text phrase.
     
  5. 1975

    1975 Member

    I've modified all of the "user_lost_password_*" for testing purposes and I can modify the SUBJECT and FIRST LINE of the email but not the text below:

    User Name: 1975,
    Password:
    xi9e9cc8

    Log in

    Thanks.
    domain.com

    -------------------

    I've went to check /library/XenForo/Model/UserConfirmation.php and it shows:

    $mail = XenForo_Mail::create('user_lost_password_reset', $params, $user['language_id']);

    That is not in my phrases section, only the ones below:

    1. user_lost_password_body_html
    2. user_lost_password_body_text
    3. user_lost_password_reset_body_html
    4. user_lost_password_reset_body_text
    5. user_lost_password_reset_subject
    6. user_lost_password_subject


    Any ideas from here?
     
  6. Brogan

    Brogan XenForo Moderator Staff Member

  7. 1975

    1975 Member

    Thanks Brogan! Exactly what I was looking for... THAT FIXED IT! :cool:

    debug mode > development tab > email templates
     

Share This Page