1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 1.2.5 XF to 1.4.5 Import Error (Help Please)

Discussion in 'Installation, Upgrade, and Import Support' started by Joykiller, Apr 21, 2015.

  1. Joykiller

    Joykiller Member

    Having a slight issue with importing Users, have tried each of the following options and still receive the same error result.
    • When email addresses are the same
    • When names are the same
    • Search for Gravatar when users do not have an avatar
    Error
    Please enter a valid value.

    I have debugging mode on but do not see any more information, is there a log file with more details of this error somewhere I can view?

    Question: Which would be better, Fresh 1.4.5 import then Addon install or Fresh 1.4.5 install addons then Import. Would both work the same?
     
  2. Mike

    Mike XenForo Developer Staff Member

    Do you have any add-ons installed? It's possible there's some amount of interference there. I would recommend importing without add-ons installed (or at least enabled) to test.

    Another alternative would be to upgrade the 1.2.5 forum to 1.4 first, though I don't believe there should be any problems importing from 1.2.
     
  3. Joykiller

    Joykiller Member

    Yeah thats what i thought, however I have already installed addons into 1.4.5 fresh build. I did try however to have all addons disabled. (Not uninstalled. just disabled) still same issue.

    I think i'll wipe really quick re install fresh and re import and see how that works out.
     
  4. Joykiller

    Joykiller Member

    Fresh install, same result on User Import section.

    Error
    Please enter a valid value.
     
  5. Joykiller

    Joykiller Member

    You think I should try 1.2.5 to 1.4 then upgrade to 1.4.5?
     
  6. Mike

    Mike XenForo Developer Staff Member

    You can upgrade it direct to 1.4.5 -- I just said 1.4 as the specific version shouldn't matter.

    Do you have add-ons installed in the 1.2 version? I'm looking at the changes to the user data writer between 1.2 and 1.4 and I really don't see anything that should trigger this.

    Alternatively, if you submit a ticket with ACP and FTP details, I can give you a more specific reason why this is happening.
     
  7. Joykiller

    Joykiller Member

    Yeah the only thing that im aware of was the ******* Credits should I purge those fields? That added new fields to the XF_User table.
     
  8. Mike

    Mike XenForo Developer Staff Member

    I don't think the fields should be relevant. May be easiest for me to take a look at what's triggering the error specifically.
     
  9. Joykiller

    Joykiller Member

    Yeah, thats not going to happen as my license just ran out last month, update license not on the budget atm. I'll try on my own, any pointers?
     
  10. Mike

    Mike XenForo Developer Staff Member

    You can attempt the upgrade method then, but that's really all I could suggest. (Even if there were a fix, it would be part of the next release anyway.)
     
  11. Joykiller

    Joykiller Member

    @Mike Quick question, Do you think it would be best practice to copy over all the files then change config to the older db for it to update to 1.4.5? Or use fresh 1.4.5 files with the old DB so it does an upgrade then go and remove uninstalled Addons etc?
     
  12. Mike

    Mike XenForo Developer Staff Member

    Well, I haven't actually asked why you're doing a XenForo-to-XenForo import. If you're trying to "clean" the forum, I'd generally recommend not doing an import and actually just cleaning up what you have. An import will always lose some amount of data.

    To be safe, if you're doing an upgrade, I wouldn't just change the config.php to point to a different DB as your data/ and internal_data/ files won't be pointing to the correct set of files. (This shouldn't be a problem in most cases, but to be certain...)
     
  13. Joykiller

    Joykiller Member

    Because I'm using a local copy to test out and work on things before I push to live was just wondering what would be the best method to shutdown replace then open back up for less down time.

    And yeah XF to XF was for doing a clean up.
     
  14. Brogan

    Brogan XenForo Moderator Staff Member

    Joykiller likes this.
  15. Joykiller

    Joykiller Member

    Good to know about the file things I learned a few things from that post. Hopefully this will help a tad, thx.
     
  16. Joykiller

    Joykiller Member

Share This Page