• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

1.1.0 Upgrade Error

#1
"The following errors occurred while verifying that your server can run XenForo:
  • The directory /home4/gothamho/public_html/collegehoopschat/install/internal_data must be writable. Please change the permissions on this directory to be world writable (chmod 0777). If the directory does not exist, please create it.
Please correct these errors and try again."

How do I fix this? Thanks!
 

ShadyX

Well-known member
#4
You need to change the permissions on the install folder (and subfolders) to 777 so xenforo can write data during the install/upgrade.
 

Mike

XenForo developer
Staff member
#8
The install folder should not be 0777. Though I can see why with that slightly buggy error message -- the internal_data directory in the root should be 0777, as well as everything below it.
 

Mike

XenForo developer
Staff member
#9
Actually, the extra "install" in there makes me wonder if all of the files were uploaded correctly.
 

Mike

XenForo developer
Staff member
#11
I'd try reuploading all files first. Then, you just need to make sure that the data and internal_data directories (and contents within) are 0777.
 
#17
I've definitely messed up somewhere down the line. Either by uploading the new upgrade files too many times as well as changing my permission settings to 777 for folders and files. Need help on getting things organized and up and running on 1.1.0
 

borbole

Well-known member
#19
I've definitely messed up somewhere down the line. Either by uploading the new upgrade files too many times as well as changing my permission settings to 777 for folders and files. Need help on getting things organized and up and running on 1.1.0
Chmodding the files and following the guide linked above should fix your issue and get your forum upgraded. Alternatively you can also purchase a professional service upgrade from the xenforo staff if you still have difficulties with it.