1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XenForo LiteSpeed Cache 1.1.0 Release

Massively reduce your database queries when running LiteSpeed Web Server.

  1. Slavik

    Slavik XenForo Moderator Staff Member

    Slavik submitted a new resource:

    XenForo LiteSpeed Cache - Massively reduce your database queries when running LiteSpeed Web Server.

    Read more about this resource...
    lsmichael, eagle eyes, t0fx and 3 others like this.
  2. Alfa1

    Alfa1 Well-Known Member

    Thank you thank you thank you!!!
  3. Slavik

    Slavik XenForo Moderator Staff Member

  4. Max

    Max Active Member

    Best X'mas + New Year gift! :D Woow
    Thank you Slavik and Extralicense!
    Earl likes this.
  5. Max

    Max Active Member

    Is this compatible/can cache with Multisite plugin used sites with different domains and sub domains?
    Alfa1 likes this.
  6. TheBigK

    TheBigK Well-Known Member

    Wolla Wolla! Is this add-on idiot proof that someone who's running LiteSpeed in its default configuration (through WHM plugin) can install and have no issues?
  7. Slavik

    Slavik XenForo Moderator Staff Member

    Nope, read the install instructions.

    No idea how the multisite addon works or functions technically, so can't comment. Give it a try, I guess.
  8. JordanH

    JordanH Active Member

    Wow very amazing!
  9. Alfa1

    Alfa1 Well-Known Member

    I would love to know this as well. If you try it, please post the results. I'm currently in import & development phase, so cant try it out yet.
  10. Max

    Max Active Member

    If you want i can give the licensed plugin to test. I am still not using it in a live site.
    I can test it my self but don't have enough knowledge about litespeed cache to give conclusions or debug issues.
  11. Max

    Max Active Member

    same here bro. Still not on a live site and have no expert skills on litespeed cache to identify problems with the plugin.
  12. allewreK

    allewreK Active Member

    It doesn't works for me :
    • Addon installed (members haven't been disconnected during the installation process).
    • Litespeed configured.
    • .htaccess lines added.
  13. ExtraLicense

    ExtraLicense Well-Known Member

    Do you use a cache for the sessions or are they stored in the db?
  14. allewreK

    allewreK Active Member

    Here is my actual config.php file (I don't think I'm caching the sessions) :
    PHP:
    $config['cache']['enabled'] = true;

    $config['cache']['frontend'] = 'Core';
    $config['cache']['frontendOptions']['cache_id_prefix'] = 'xf_';

    $config['cache']['backend'] = 'File';
    $config['cache']['backendOptions']['hashed_directory_level'] = '2';

    /*$config['cache']['backend'] = 'File';
    $config['cache']['backendOptions']['hashed_directory_level'] = '1';/

    /*$config['cache']['cacheSessions'] = true;*/
  15. allewreK

    allewreK Active Member

    It's really strange, I manually truncated the xf_session table, but it doesn't log out anyone.

    So the addon looks working, the only problem is that since I can't log out my members, none have the "skipCache" cookie.
  16. Slavik

    Slavik XenForo Moderator Staff Member

    When logged in, do you have a skipPageCache cookie?
  17. Moshe1010

    Moshe1010 Well-Known Member

    Any examples of live forums that are running this plugin?
  18. allewreK

    allewreK Active Member

    No, since my members are not logged out, none have the skipPageCache cookie (so anyone can see a random member or guest's view ^^).
  19. Slavik

    Slavik XenForo Moderator Staff Member

    If your not caching the sessions, you must have something altering them in some way or something, considering the install code truncates the xf session table.
  20. allewreK

    allewreK Active Member

    That's really strange since I trucated the xf_session table (it was empty), and none have been disconnected.

Share This Page