1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

[8wayRun.Com] XenPorta (Portal) 1.6.0

Portal, News and Articles... and a widget framework.

  1. Jaxel

    Jaxel Well-Known Member

    Rob H, nlmquan, freecode and 5 others like this.
  2. Jaxel

    Jaxel Well-Known Member

    nlmquan and Renada like this.
  3. Digital Doctor

    Digital Doctor Well-Known Member

    [​IMG]

    Check it out! XenPorta User Guide and FAQs by Saeed.


    XenPorta is simply the best and most popular Xenforo Addon available today.
    Where would Xenforo be without it ! I shudder to think.
    Great work Jaxel.
    Breixo, Earl, DRE and 2 others like this.
  4. optrex

    optrex Active Member

    I've managed to get the recent news to display on the portal page, but I would like it on my XF forum home page to display above the list of forums. It seems to display partly using "index", in that I can get the history navigation numbers to show but nothing else.

    I've emptied the cache. Any pointers please? Its something that is currently very high on my priority list to get fixed.

    I imagine I need to globalise a hook in a similar way to

    At the absolute bottom of "thread_view"
    <xen:hook name="thread_view_share_after" params="{xen:array 'thread={$thread}'}" />

    At the absolute bottom of "forum_view"
    <xen:hook name="forum_view_pagenav_after" params="{xen:array 'forum={$forum}'}" />

    But I need to know which hook and which template I need to edit.
  5. netrix

    netrix Active Member

    Which rights need to be set for using the categories.
  6. ddmmh

    ddmmh Well-Known Member

    Hi Jaxel,

    Possible bug? I created a category 'Australian MMA' with link 'australian-mma' when I got taken back to categories it wasnt there so I tried to created it again and got the duplication error below.

    Also the category does show and work from the Portal, I just cant see it in the Admin section, so I cant edit or remove it.

    Created another category Strikeforce and it worked fine, maybe doesnt like spaces in the category name???

    Code:
    Server Error
     
    Mysqli statement execute error : Duplicate entry 'australian-mma' for key 2
     
    Zend_Db_Statement_Mysqli->_execute() in Zend/Db/Statement.php at line 297
    Zend_Db_Statement->execute() in Zend/Db/Adapter/Abstract.php at line 479
    Zend_Db_Adapter_Abstract->query() in Zend/Db/Adapter/Abstract.php at line 574
    Zend_Db_Adapter_Abstract->insert() in XenForo/DataWriter.php at line 1591
    XenForo_DataWriter->_insert() in XenForo/DataWriter.php at line 1580
    XenForo_DataWriter->_save() in XenForo/DataWriter.php at line 1381
    XenForo_DataWriter->save() in EWRporta/Model/Categories.php at line 94
    EWRporta_Model_Categories->updateCategory() in EWRporta/ControllerAdmin/Categories.php at line 54
    EWRporta_ControllerAdmin_Categories->actionSave() in XenForo/FrontController.php at line 310
    XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 132
    XenForo_FrontController->run() in /home/ddmmh/public_html/community/admin.php at line 13
  7. simbolo

    simbolo Well-Known Member

    Possible bug within EWR_ArticleView.html

    Checked $thread.first_post_id via {xen:helper dump, $thread.first_post_id} and it returned 0 which means the first post will be displayed. Should it be getting passed in?
  8. Itworx4me

    Itworx4me Well-Known Member

    Jaxel can you explain how to use the new Category function. I see no documentation in the mod itself.

    Thanks,
    Itworx4me
  9. Daniel Thomann

    Daniel Thomann Active Member

    After upgrading / installing XenPorta 1.5.2, you have a new submenu-item in the ACP -> Home (menu XenPorta) called 'categories'. There you should create first a test category.
    Once created, go to the ACP -> Home -> XenPorta -> Options menu and check the option (Globalized Custom Layouts):
    Article (article-# > article > portal)
    Categories (articles-#slug > articles > portal)

    After that, go to the Portal Index and click on a recent news item. you should notice, that the view of the thread / article has changed. Go to the bottom of the message.
    There you should see: "Categories: Uncategorized".
    To the right, you have the option "edit". There you can assign the categories that you predefined in the ACP.

    Should we release custom XenPorta Blocks as own resources or here?
  10. ddmmh

    ddmmh Well-Known Member

    Its quite easy, in your admin CP go to categories, create them. Then when you add a post to the portal at the bottom there is an edit button to add them to the categories. Then you can link to them whichever way you want so people only see the categories they choose. I believe this can be developed greatly and im sure Jaxel will do that in the upcoming releases
  11. principia

    principia Well-Known Member

    @Jaxel
    After installing the new version i have got an old error, that was fixed by me with a Patch posted some days ago.

    Why do you have not integrate this patch?

    See here:
    To work around the problem open @xenforoinstallpath/library/EWRporta/ControllerPublic/Forum.php
    search:
    Code:
    $response->params['layout1'] = 'forum-'.$response->params['forum']['node_id'];
    replace with:
    Code:
    $node_id = (!empty($response->params['forum']['node_id'])) ? $response->params['forum']['node_id'] : 0;
    $response->params['layout1'] = 'forum-'.$node_id;
    rgourley and Daniel Thomann like this.
  12. Daniel Thomann

    Daniel Thomann Active Member

    I agree... the global rss gives me an error without that fix...
    as stated here: http://xenforo.com/community/threads/8wayrun-com-xenporta-portal.7586/page-200#post-314957
  13. DRE

    DRE Previously 8thos

    Since is the new Xenporta Blocks thread, have any of you managed to get a second slider working for a separate forum?
  14. Daniel Thomann

    Daniel Thomann Active Member

    This isn't the modules thread. this is the portal thread. the modules thread is missing.
    @Jaxel: probabbly it would be the best to open a thread here: http://xenforo.com/community/forums/resource-and-add-on-discussions.63/
  15. mmoore5553

    mmoore5553 Well-Known Member

    Okay I have been going over this for hours. I am unsure why I setup a layout for the portal and then setup a layout for forum ; the forum does not show what I changed. I added a layout called forum-## and I did not give it ID and still same situation.


    Nevermind i figured out that the forum is called index not forum
  16. mmoore5553

    mmoore5553 Well-Known Member

    Is there a way to have it where I have a sidebar on one side and then content and then sidebar on other side ? I just want to change it a tad and maybe have layout in bottom that is split ?
  17. kkm323

    kkm323 Well-Known Member

    I appreciate your hard work and effort to present to us one of the most useble and likble coding mod. thank you
    I would like to know more about the widgets that are available with mod and if there is the latest threads widget?
  18. Itworx4me

    Itworx4me Well-Known Member

    When I upgraded to 1.5.2 it reverted all my custom setting for the modules back to default. Bummer...... Looks to be a Bug....Anyone else get this?
  19. DRE

    DRE Previously 8thos

  20. dragonhib

    dragonhib Member

    What about custom portal pages based on layout ?

    I had a custom additional portal page at /portal/custom/index and since upgrading I can't find them. Any idea ? Is this fonctionality removed ?

Share This Page